背驰指标公式主图F10源码-通达信公式-操盘手公式网
股票软件 通达信 大智慧 飞狐 同花顺 东财通 操盘手 指南针 钱龙 券商软件 手机炒股 破解版 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 通达信 大智慧 飞狐 同花顺 东财通 | 股票池 通达信 | 大智慧| 股票书籍 | 指标分类 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ
当前位置:首页 >> 指标公式 >>  通达信公式
股票配资开户注册领取2019元现金
私募操盘手内部培训视频
背驰指标公式主图F10源码
  • 相关简介: 测试已通过
  • 内容标签: 背驰指标公式,主图F10源码
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 软件作者: 操盘手公式网
  • 软件来源: www.stock87.com
  • 加入时间: 2019-11-30 18:49:56
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
  • 软件使用说明:(注:已有源码的公式只需要复制源码,不提供文件下载!)

    背驰指标公式主图F10源码

    指标一开始用可能觉得比较繁锁,用习惯了还是非常不错的,F10显示得很详细,基本上能判断出个股性的好坏了,不用再去看基本面了。

    X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
    X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
    X3:=FINANCE(23)/FINANCE(10)*3.3;
    X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
    X5:=FINANCE(20)/FINANCE(15)*0.999;
    Z值:=X1+X2+X3+X4+X5;
    预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));
    财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));
    优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/
    FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
    现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
    财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));
    {}
    DRAWTEXT_FIX(ISLASTBAR,0.005,0,0,所属板块),COLORYELLOW;
    DRAWTEXT_FIX(ISLASTBAR,0.005,0.06,0,股本市值),COLORGRAY;
    DRAWTEXT_FIX(ISLASTBAR,0.005,0.12,0,当前业绩),COLORGRAY;
    DRAWTEXT_FIX(ISLASTBAR,0.005,0.18,0,财务系数),COLORGRAY;
    {成本分布}
    CB90:=STRCAT('成本90: ',CON2STR(COST(90),2));
    CB70:=STRCAT('成本70: ',CON2STR(COST(70),2));
    CB50:=STRCAT('成本50: ',CON2STR(COST(50),2));
    CB30:=STRCAT('成本30: ',CON2STR(COST(30),2));
    CB10:=STRCAT('成本10: ',CON2STR(COST(10),2));
    CB底:=STRCAT('底部出击: ',CON2STR(COST(0.33),2));
    DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1,0.18,0,CB90),COLORGREEN;
    DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1,0.24,0,CB70),COLORYELLOW;
    DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1,0.30,0,CB50),COLORLIBLUE;
    DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1,0.36,0,CB30),COLORGREEN;
    DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1,0.42,0,CB10),COLORYELLOW;
    DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1,0.48,0,CB底),COLORWHITE;
    AJ1:=0.211916*C+0.192951*REF(C,1)+0.158082*REF(C,2)+0.122217*REF(C,3)+0.091137*REF(C,4)+0.066337
    *REF(C,5)+0.047475*REF(C,6)+0.033564*REF(C,7)+0.023519*REF(C,8)+0.016373*REF(C,9)+0.011344
    *REF(C,10)+0.007832*REF(C,11)+0.005395*REF(C,12)+0.00371*REF(C,13)+0.002549*REF(C,14)+0.001751
    *REF(C,15)+0.001203*REF(C,16)+0.000826*REF(C,17)+0.000568*REF(C,18)+0.000391*REF(C,19)+0.000269
    *REF(C,20);
    YYU:AJ1+0.000185*REF(C,21)+0.000128*REF(C,22)+0.000088*REF(C,23)+0.000061*REF(C,24)+0.000042
    *REF(C,25)+0.000029*REF(C,26)+0.00002*REF(C,27)+0.000014*REF(C,28)+0.000009*REF(C,29)+0.000006
    *REF(C,30)+0.000003*REF(C,31)+0.000002*REF(C,32)+0.000001*REF(C,33)+0.000001*REF(C,34),COLORGREEN;
    中轨:EMA(YYU,30),COLORGREEN,LINETHICK2;
    IF(中轨>REF(中轨,1),中轨,DRAWNULL),COLORRED,LINETHICK2;

    X00:=C;
    X01:=0.7522406533*X00+0.3609454219*REF(X00,1)-0.03309329629*REF(X00,2)-
    0.04241822779*REF(X00,3)-0.026737249*REF(X00,4)-0.007010041271*REF(X00,5)-
    0.002652859952*REF(X00,6)-0.0008415042966*REF(X00,7)-0.0002891931964*REF
    (X00,8)-0.0000956265934*REF(X00,9)-0.0000321286052*REF(X00,10)-
    0.0000106773454*REF(X00,11)-0.0000035457562*REF(X00,12)-0.0000011670713*REF
    (X00,13);
    X02:=0.7522406533*X01+0.3609454219*REF(X01,1)-0.03309329629*REF(X01,2)-
    0.04241822779*REF(X01,3)-0.026737249*REF(X01,4)-0.007010041271*REF(X01,5)-
    0.002652859952*REF(X01,6)-0.0008415042966*REF(X01,7)-0.0002891931964*REF
    (X01,8)-0.0000956265934*REF(X01,9)-0.0000321286052*REF(X01,10)-
    0.0000106773454*REF(X01,11)-0.0000035457562*REF(X01,12)-0.0000011670713*REF
    (X01,13);
    X03:=0.7522406533*X02+0.3609454219*REF(X02,1)-0.03309329629*REF(X02,2)-
    0.04241822779*REF(X02,3)-0.026737249*REF(X02,4)-0.007010041271*REF(X02,5)-
    0.002652859952*REF(X02,6)-0.0008415042966*REF(X02,7)-0.0002891931964*REF
    (X02,8)-0.0000956265934*REF(X02,9)-0.0000321286052*REF(X02,10)-
    0.0000106773454*REF(X02,11)-0.0000035457562*REF(X02,12)-0.0000011670713*REF
    (X02,13);

    AA:((EMA((((EMA(X01,22)+EMA(X01,23))+EMA(X01,24))/3),2))+(EMA((((EMA
    (X01,24)+EMA(X01,25))+EMA(X01,26))/3),2))+(EMA((((EMA(X01,26)+EMA(X01,27))
    +EMA(X01,28))/3),2))+(EMA((((EMA(X01,28)+EMA(X01,29))+EMA(X01,30))/3),2))+
    (EMA((((EMA(X01,30)+EMA(X01,31))+EMA(X01,32))/3),2))+(EMA((((EMA(X01,32)+EMA
    (X01,33))+EMA(X01,34))/3),2)))/6,COLORWHITE;
    BB1:=(X01*5+X02*3+X03*1)/9;
    VTR2:=LLV(LOW,10);
    VTR3:=HHV(HIGH,25);
    动力线:=EMA((CLOSE-VTR2)/(VTR3-VTR2)*4,4)*20;
    上轨:MA(REF(HHV(C,30),1),2),COLORLIRED,LINETHICK2;
    下轨:MA(REF(LLV(C,30),1),2),COLORCD6C32,LINETHICK2;
    QS:=IF(C>REF(C,1),(2*CLOSE+2*HIGH+OPEN+LOW)/6,(2*OPEN+2*LOW+CLOSE+HIGH)/6);
    短轨:=SMA(C,3,1);
    趋势:=SMA(短轨,3,1),COLORCYAN;
    短线:MA(SMA(QS,5,1),3),COLOR60A9B9,LINETHICK2;
    道线:EMA(BB1,233)COLORLIGRAY,CROSSDOT;
    均角:ATAN((短线/REF(短线,1)-1)*100)*180/3.14115926,NODRAW;

    A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
    A4:=SMA(A3,3,1);
    A5:=SMA(A4,3,1);
    A6:=3*A4-2*A5;
    A7:=C-REF(C,1);
    A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
    买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));

    STICKLINE(买,OPEN,CLOSE,2,0),COLORYELLOW;

    BIAS1 :=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
    BIAS2 :=(CLOSE-MA(CLOSE,1))/MA(CLOSE,1)*100;
    DRAWICON(CROSS(BIAS1,BIAS2),L,17);

    RSI5:=((SMA(MAX((CLOSE - REF(CLOSE,1)),0),5,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),5,1)) * 100);
    TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
    HD:=(HIGH - REF(HIGH,1));
    LD:=(REF(LOW,1) - LOW);
    DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
    DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
    PDI:=((DMP * 100) / TR1);
    MDI:=((DMM * 100) / TR1);
    ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
    AV:=(RSI5 + ADX);
    DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
    WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
    NEWVOL:=(RSI5 - WR10);
    回调买:=(AV + NEWVOL);
    XGT:=CROSS(回调买,0) AND 下轨<REF(下轨,1)  AND 均角<-30 AND 动力线<15 ;
    DRAWTEXT(XGT,L-0.05,'←回调买'),COLORYELLOW;
    M5:=EMA((5*CLOSE+4*REF(CLOSE,1)+3*REF(CLOSE,2)+2*REF(CLOSE,3)+REF(CLOSE,4))/15,1),COLORWHITE;
    M10:=EMA((10*CLOSE+9*REF(CLOSE,1)+8*REF(CLOSE,2)+7*REF(CLOSE,3)+6*REF(CLOSE,4)+5*REF(CLOSE,5)+4*REF(CLOSE,6)+3*REF(CLOSE,7)+2*REF(CLOSE,8)+REF(CLOSE,9))/55,1),COLORAFAF5F;
    M20:=EMA((20*CLOSE+19*REF(CLOSE,1)+18*REF(CLOSE,2)+17*REF(CLOSE,3)+16*REF(CLOSE,4)+15*REF(CLOSE,5)+14*REF(CLOSE,6)+13*REF(CLOSE,7)+12*REF(CLOSE,8)+11*REF(CLOSE,9)+10*REF(CLOSE,10)+9*REF(CLOSE,11)+8*REF(CLOSE,12)+7*REF(CLOSE,13)+6*REF(CLOSE,14)+5*REF(CLOSE,15)+4*REF(CLOSE,16)+3*REF(CLOSE,17)+2*REF(CLOSE,18)+REF(CLOSE,19))/210,1),COLORLIRED;
    ZL31:=(30*CLOSE+29*REF(CLOSE,1)+28*REF(CLOSE,2)+27*REF(CLOSE,3)+26*REF(CLOSE,4)+25*REF(CLOSE,5)+24*REF(CLOSE,6)+23*REF(CLOSE,7)+22*REF(CLOSE,8)+21*REF(CLOSE,9)+20*REF(CLOSE,10)+19*REF(CLOSE,11)+18*REF(CLOSE,12)+17*REF(CLOSE,13)+16*REF(CLOSE,14)+15*REF(CLOSE,15)+14*REF(CLOSE,16)+13*REF(CLOSE,17)+12*REF(CLOSE,18)+11*REF(CLOSE,19));
    ZL32:=(10*REF(CLOSE,20)+9*REF(CLOSE,21)+8*REF(CLOSE,22)+7*REF(CLOSE,23)+6*REF(CLOSE,24)+5*REF(CLOSE,25)+4*REF(CLOSE,26)+3*REF(CLOSE,27)+2*REF(CLOSE,28)+REF(CLOSE,29));
    M30:=EMA((ZL31+ZL32)/465,1),COLORLIMAGENTA;
    ZL41:=(45*CLOSE+44*REF(CLOSE,1)+43*REF(CLOSE,2)+42*REF(CLOSE,3)+41*REF(CLOSE,4)+40*REF(CLOSE,5)+39*REF(CLOSE,6)+38*REF(CLOSE,7)+37*REF(CLOSE,8)+36*REF(CLOSE,9)+35*REF(CLOSE,10)+34*REF(CLOSE,11)+33*REF(CLOSE,12)+32*REF(CLOSE,13)+31*REF(CLOSE,14)+30*REF(CLOSE,15)+29*REF(CLOSE,16)+28*REF(CLOSE,17)+27*REF(CLOSE,18)+26*REF(CLOSE,19));
    ZL42:=(25*REF(CLOSE,20)+24*REF(CLOSE,21)+23*REF(CLOSE,22)+22*REF(CLOSE,23)+21*REF(CLOSE,24)+20*REF(CLOSE,25)+19*REF(CLOSE,26)+18*REF(CLOSE,27)+17*REF(CLOSE,28)+16*REF(CLOSE,29)+15*REF(CLOSE,30)+14*REF(CLOSE,31)+13*REF(CLOSE,32)+12*REF(CLOSE,33)+11*REF(CLOSE,34)+10*REF(CLOSE,35)+9*REF(CLOSE,36)+8*REF(CLOSE,37)+7*REF(CLOSE,38)+6*REF(CLOSE,39)+5*REF(CLOSE,40)+4*REF(CLOSE,41)+3*REF(CLOSE,42)+2*REF(CLOSE,43)+REF(CLOSE,44));
    M45:=(ZL41+ZL42)/1035,COLORE8E800;
    ZL61:=(60*CLOSE+59*REF(CLOSE,1)+58*REF(CLOSE,2)+57*REF(CLOSE,3)+56*REF(CLOSE,4)+55*REF(CLOSE,5)+54*REF(CLOSE,6)+53*REF(CLOSE,7)+52*REF(CLOSE,8)+51*REF(CLOSE,9)+50*REF(CLOSE,10)+49*REF(CLOSE,11)+48*REF(CLOSE,12)+47*REF(CLOSE,13)+46*REF(CLOSE,14)+45*REF(CLOSE,15)+44*REF(CLOSE,16)+43*REF(CLOSE,17)+42*REF(CLOSE,18)+41*REF(CLOSE,19));
    ZL62:=(40*REF(CLOSE,20)+39*REF(CLOSE,21)+38*REF(CLOSE,22)+37*REF(CLOSE,23)+36*REF(CLOSE,24)+35*REF(CLOSE,25)+34*REF(CLOSE,26)+33*REF(CLOSE,27)+32*REF(CLOSE,28)+31*REF(CLOSE,29)+30*REF(CLOSE,30)+29*REF(CLOSE,31)+28*REF(CLOSE,32)+27*REF(CLOSE,33)+26*REF(CLOSE,34)+25*REF(CLOSE,35)+24*REF(CLOSE,36)+23*REF(CLOSE,37)+22*REF(CLOSE,38)+21*REF(CLOSE,39));
    ZL63:=(20*REF(CLOSE,40)+19*REF(CLOSE,41)+18*REF(CLOSE,42)+17*REF(CLOSE,43)+16*REF(CLOSE,44)+15*REF(CLOSE,45)+14*REF(CLOSE,46)+13*REF(CLOSE,47)+12*REF(CLOSE,48)+11*REF(CLOSE,49)+10*REF(CLOSE,50)+9*REF(CLOSE,51)+8*REF(CLOSE,52)+7*REF(CLOSE,53)+6*REF(CLOSE,54)+5*REF(CLOSE,55)+4*REF(CLOSE,56)+3*REF(CLOSE,57)+2*REF(CLOSE,58)+REF(CLOSE,59));
    M60:=EMA((ZL61+ZL62+ZL63)/1830,1),COLORLIBLUE;
    ZL91:=(90*CLOSE+89*REF(CLOSE,1)+88*REF(CLOSE,2)+87*REF(CLOSE,3)+86*REF(CLOSE,4)+85*REF(CLOSE,5)+84*REF(CLOSE,6)+83*REF(CLOSE,7)+82*REF(CLOSE,8)+81*REF(CLOSE,9)+80*REF(CLOSE,10)+79*REF(CLOSE,11)+78*REF(CLOSE,12)+77*REF(CLOSE,13)+76*REF(CLOSE,14)+75*REF(CLOSE,15)+74*REF(CLOSE,16)+73*REF(CLOSE,17)+72*REF(CLOSE,18)+71*REF(CLOSE,19));
    ZL92:=(70*REF(CLOSE,20)+69*REF(CLOSE,21)+68*REF(CLOSE,22)+67*REF(CLOSE,23)+66*REF(CLOSE,24)+65*REF(CLOSE,25)+64*REF(CLOSE,26)+63*REF(CLOSE,27)+62*REF(CLOSE,28)+61*REF(CLOSE,29)+60*REF(CLOSE,30)+59*REF(CLOSE,31)+58*REF(CLOSE,32)+57*REF(CLOSE,33)+56*REF(CLOSE,34)+55*REF(CLOSE,35)+54*REF(CLOSE,36)+53*REF(CLOSE,37)+52*REF(CLOSE,38)+51*REF(CLOSE,39));
    ZL93:=(50*REF(CLOSE,40)+49*REF(CLOSE,41)+48*REF(CLOSE,42)+47*REF(CLOSE,43)+46*REF(CLOSE,44)+45*REF(CLOSE,45)+44*REF(CLOSE,46)+43*REF(CLOSE,47)+42*REF(CLOSE,48)+41*REF(CLOSE,49)+40*REF(CLOSE,50)+39*REF(CLOSE,51)+38*REF(CLOSE,52)+37*REF(CLOSE,53)+36*REF(CLOSE,54)+35*REF(CLOSE,55)+34*REF(CLOSE,56)+33*REF(CLOSE,57)+32*REF(CLOSE,58)+31*REF(CLOSE,59));
    ZL94:=(30*REF(CLOSE,60)+29*REF(CLOSE,61)+28*REF(CLOSE,62)+27*REF(CLOSE,63)+26*REF(CLOSE,64)+25*REF(CLOSE,65)+24*REF(CLOSE,66)+23*REF(CLOSE,67)+22*REF(CLOSE,68)+21*REF(CLOSE,69)+20*REF(CLOSE,70)+19*REF(CLOSE,71)+18*REF(CLOSE,72)+17*REF(CLOSE,73)+16*REF(CLOSE,74)+15*REF(CLOSE,75)+14*REF(CLOSE,76)+13*REF(CLOSE,77)+12*REF(CLOSE,78)+11*REF(CLOSE,79));
    ZL95:=10*REF(CLOSE,80)+9*REF(CLOSE,81)+8*REF(CLOSE,82)+7*REF(CLOSE,83)+6*REF(CLOSE,84)+5*REF(CLOSE,85)+4*REF(CLOSE,86)+3*REF(CLOSE,87)+2*REF(CLOSE,88)+REF(CLOSE,89);
    M90:=(ZL91+ZL92+ZL93+ZL94+ZL95)/4095,COLORLICYAN;
    ZL13:=(120*CLOSE+119*REF(CLOSE,1)+118*REF(CLOSE,2)+117*REF(CLOSE,3)+116*REF(CLOSE,4)+115*REF(CLOSE,5)+114*REF(CLOSE,6)+113*REF(CLOSE,7)+112*REF(CLOSE,8)+111*REF(CLOSE,9)+110*REF(CLOSE,10)+109*REF(CLOSE,11)+108*REF(CLOSE,12)+107*REF(CLOSE,13)+106*REF(CLOSE,14)+105*REF(CLOSE,15)+104*REF(CLOSE,16)+103*REF(CLOSE,17)+102*REF(CLOSE,18)+101*REF(CLOSE,19));
    ZL14:=(100*REF(CLOSE,20)+99*REF(CLOSE,21)+98*REF(CLOSE,22)+97*REF(CLOSE,23)+96*REF(CLOSE,24)+95*REF(CLOSE,25)+94*REF(CLOSE,26)+93*REF(CLOSE,27)+92*REF(CLOSE,28)+91*REF(CLOSE,29)+90*REF(CLOSE,30)+89*REF(CLOSE,31)+88*REF(CLOSE,32)+87*REF(CLOSE,33)+86*REF(CLOSE,34)+85*REF(CLOSE,35)+84*REF(CLOSE,36)+83*REF(CLOSE,37)+82*REF(CLOSE,38)+81*REF(CLOSE,39));
    ZL15:=(80*REF(CLOSE,40)+79*REF(CLOSE,41)+78*REF(CLOSE,42)+77*REF(CLOSE,43)+76*REF(CLOSE,44)+75*REF(CLOSE,45)+74*REF(CLOSE,46)+73*REF(CLOSE,47)+72*REF(CLOSE,48)+71*REF(CLOSE,49)+70*REF(CLOSE,50)+69*REF(CLOSE,51)+68*REF(CLOSE,52)+67*REF(CLOSE,53)+66*REF(CLOSE,54)+65*REF(CLOSE,55)+64*REF(CLOSE,56)+63*REF(CLOSE,57)+62*REF(CLOSE,58)+61*REF(CLOSE,59));
    ZL16:=(60*REF(CLOSE,60)+59*REF(CLOSE,61)+58*REF(CLOSE,62)+57*REF(CLOSE,63)+56*REF(CLOSE,64)+55*REF(CLOSE,65)+
    54*REF(CLOSE,66)+53*REF(CLOSE,67)+52*REF(CLOSE,68)+51*REF(CLOSE,69)+50*REF(CLOSE,70)+49*REF(CLOSE,71)+48*REF(CLOSE,72)+47*REF(CLOSE,73)+46*REF(CLOSE,74)+45*REF(CLOSE,75)+44*REF(CLOSE,76)+43*REF(CLOSE,77)+42*REF(CLOSE,78)+41*REF(CLOSE,79));
    ZL17:=(40*REF(CLOSE,80)+39*REF(CLOSE,81)+38*REF(CLOSE,82)+37*REF(CLOSE,83)+36*REF(CLOSE,84)+35*REF(CLOSE,85)+34*REF(CLOSE,86)+33*REF(CLOSE,87)+32*REF(CLOSE,88)+31*REF(CLOSE,89)+30*REF(CLOSE,90)+29*REF(CLOSE,91)+28*REF(CLOSE,92)+27*REF(CLOSE,93)+26*REF(CLOSE,94)+25*REF(CLOSE,95)+24*REF(CLOSE,96)+23*REF(CLOSE,97)+22*REF(CLOSE,98)+21*REF(CLOSE,99));
    ZL18:=(20*REF(CLOSE,100)+19*REF(CLOSE,101)+18*REF(CLOSE,102)+17*REF(CLOSE,103)+16*REF(CLOSE,104)+15*REF(CLOSE,105)+14*REF(CLOSE,106)+13*REF(CLOSE,107)+12*REF(CLOSE,108)+11*REF(CLOSE,109)+10*REF(CLOSE,110)+9*REF(CLOSE,111)+8*REF(CLOSE,112)+7*REF(CLOSE,113)+6*REF(CLOSE,114)+5*REF(CLOSE,115)+4*REF(CLOSE,116)+3*REF(CLOSE,117)+2*REF(CLOSE,118)+REF(CLOSE,119));
    M120:=(ZL13+ZL14+ZL15+ZL16+ZL17+ZL18)/7260,COLORGRAY;
    B5:=MA(V,5);B33:=MA(V,33);B55:=MA(V,55);B135:=MA(V,135);
    MA5:=MA(C,5);MA10:=MA(C,10);MA20:=MA(C,20);MA30:=MA(C,30);MA60:=MA(C,60);
    MA33:=MA(C,33);MA55:=MA(C,55);MA120:=MA(C,120);MA250:=MA(C,250);
    DIFS:=EMA(CLOSE,12)-EMA(CLOSE,26);DEAS:=EMA(DIFS,9);
    TYP:=(H+L+C)/3;CCI:=(TYP-MA(TYP,43))/(0.015*AVEDEV(TYP,43));
    CR1:=(REF(C,1)-REF(C,2))/REF(C,2)*100<2.8;    
    M:=((CROSS(C,MA33) AND CR1 AND MA33>MA55 AND MA33>REF(MA33,1) AND MA33-MA55>0.02 AND C>MA250 AND C>MA250 AND CCI>35 AND  B5>B55 AND B33>=B55 AND DIFS<0.10)*100)+6;

    Y/2:=IF(1,MA(CLOSE,N/2),EMA(CLOSE,N/2));
    Y1:=IF(CLOSE,MA(CLOSE,1*N),EMA(CLOSE,1*N));
    Y2:=IF(CLOSE,MA(CLOSE,2*N),EMA(CLOSE,2*N));
    Y3:=IF(CLOSE,MA(CLOSE,3*N),EMA(CLOSE,3*N));
    Y4:=IF(CLOSE,MA(CLOSE,4*N),EMA(CLOSE,4*N));
    Y6:=IF(CLOSE,MA(CLOSE,6*N),EMA(CLOSE,6*N));
    Y9:=IF(CLOSE,MA(CLOSE,9*N),EMA(CLOSE,9*N));
    Y13:=IF(CLOSE,MA(CLOSE,13*N),EMA(CLOSE,13*N));
    Y20:=IF(CLOSE,MA(CLOSE,20*N),EMA(CLOSE,20*N));

    牛熊线1:=IF(PERIOD=5,Y20,IF(PERIOD=6,Y4,IF(PERIOD=7,Y1,IF(PERIOD=9,Y6,
       IF(PERIOD=10 OR PERIOD=11,Y/2,MA(C,25600)))))),COLORGREEN,DOTLINE;

    NNN:=IF(PERIOD=5,120,IF(PERIOD=6,24,IF(PERIOD=7,6,IF(PERIOD=9,40,IF(PERIOD=10,2,IF(PERIOD=4,480,480))))));
    NXH:=IF(1,IF(CAPITAL,HHV(MA(HIGH,3),NNN)*0.7,HHV(MA(HIGH,3),NNN)*0.79),
        MA(C,25600)),COLORYELLOW,POINTDOT,LINETHICK4;
    NXL:=IF(1,IF(CAPITAL,LLV(MA(LOW,3),NNN)*1.3,LLV(MA(LOW,3),NNN)*1.21),
        MA(C,25600)),COLORBLUE,POINTDOT,LINETHICK4;
    基调:MA((NXH+NXL)/2,1),COLORRED,DOTLINE;

    VPC:=基调*VOL;
    量价工作线:EMA((EMA(VPC,3)/EMA(VOL,3)+EMA(VPC,6)/EMA(VOL,6)+EMA(VPC,12)/EMA(VOL,12)+EMA(VPC,24)/EMA(VOL,24))/4,13);

    HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
    +13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
    +7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
    REF(H,20))/210,COLORBLUE,LINETHICK1;
    LL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
    +13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
    +7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
    REF(L,20))/210,COLORBLUE,LINETHICK1;
    CVC:=(HH-LL)/2;
    分离1:=基调-((CVC-基调)*CVC-基调)/基调;
    成本:MA(MA(分离1,3),3),DOTLINE,COLORWHITE;
    分离2:=成本-((C-成本)*C-成本)/成本;
    NOTEXT成本离0:EMA(EMA(分离2,3),5),COLOR485756;
    NOTEXT成本离1:EMA(EMA(分离2,3),8),COLOR2B2B2B;
    NOTEXT成本离2:EMA(EMA(分离2,3),11),COLOR604D4A;
    NOTEXT成本离3:EMA(EMA(分离2,3),14),COLOR1E1E1E;
    NOTEXT成本离4:EMA(EMA(分离2,3),17),COLOR333333;
    NOTEXT成本离5:EMA(EMA(分离2,3),20),COLOR575757;
    NOTEXT成本离6:EMA(EMA(分离2,3),23),COLOR6E6E6E;
    NOTEXT成本离7:EMA(EMA(分离2,3),26),COLOR888888;
    NOTEXT成本离8:EMA(EMA(分离2,3),30),COLORA2A2A2;
    成本离9:EMA(EMA(分离2,3),33),COLORC5C5C5;
    成本离:EMA(EMA(分离2,3),2),COLORBROWN;
    离撑压5|:=EMA(M5-(ABS(成本离9)-ABS(成本离)),20),COLORWHITE;
    离撑压20|:=EMA(M20-(ABS(成本离9)-ABS(成本离)),20),COLORFF5959;
    离撑压45|:EMA(M45-(ABS(成本离9)-ABS(成本离)),20),COLORCYAN;
    离撑压120|:=EMA(M120-(ABS(成本离9)-ABS(成本离)),20),COLORWHITE,DOTLINE;
    TP1:=CROSS(C,成本离);
    DRAWICON(TP1,LOW,34);

    P2:=(HHV(HIGH,55)-LLV(LOW,55))/EMA((CLOSE-LLV(LOW,55)),5);
    P7:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
    ALJ:=CROSS(P7,P2);
    ZNT:=REF(C,1)*1.1-C<0.01 AND H=C;
    反转:=ALJ AND ZNT ;
    STICKLINE( 反转 AND C>O,C,O,3.2,0),COLOR000066;
    STICKLINE(反转 AND C>O,C,O,2.0,0),COLOR000077;
    STICKLINE(反转 AND C>O,C,O,1.5,0),COLOR000099;
    STICKLINE(反转 AND C>O,C,O,0.9,0),COLOR0000CC;
    STICKLINE(反转 AND C>O,C,O,0.5,0),COLOR0000FF;
    STICKLINE(反转 AND C>0,O,C,0,0),COLORFFFFFF;
    STICKLINE( 反转 AND C>O AND ZNT,C*1.001,H,3.2,0),COLOR000066;
    STICKLINE(反转 AND C>O AND ZNT,C*1.005,H,2.0,0),COLOR000077;
    STICKLINE(反转 AND C>O AND ZNT,C*1.01,H,1.5,0),COLOR000099;
    STICKLINE(反转 AND C>O AND ZNT,C*1.015,H,0.9,0),COLOR0000CC;
    STICKLINE(反转 AND C>O AND ZNT,C*1.02,H,0.2,0),COLOR0000FF;
    STICKLINE(反转 AND C>0 AND ZNT,O,C*1.02,0,0),COLORFFFFFF;
    DRAWTEXT(反转,L*0.99,'【反战】'),COLORMAGENTA;
    LOWERL:=MA(L,40)*(1-19/100);
    大底:=CROSS(LOWERL,L) ;
    DRAWICON(大底,L-0.05,25);

    {通达信文字指标}
    所属板块:=STRCAT('所属板块: ',STRCAT(STRCAT(STRCAT('[行业]-',HYBLOCK),STRCAT(' [地域]-',DYBLOCK)),STRCAT(' [概念]-',GNBLOCK)));
    总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
    流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
    全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
    市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
    上市天数:=STRCAT(' 上市天数: ',CON2STR(FINANCE(42),0));
    {上市日期:=STRCAT(' 上市日期: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));}
    股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),
    上市天数));
    {}
    市盈率:=STRCAT('市盈率: ',CON2STR(C/FINANCE(33),2));
    市销率:=STRCAT(' 市销率: ',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
    市净率:=STRCAT(' 市净率: ',CON2STR(C/FINANCE(34),2));
    净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
    毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
    净利润率:=STRCAT(' 净利润率 ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
    主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
    当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率)
    ,市净率),净资收益率),毛利率),净利润率),主营利润率));
    {}

    下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)

    官方千人交流微信群1:rafczx

    官方千人交流QQ群8:1500113880




    关于我们- 广告合作- 下载声明- 下载帮助- 网站地图- 网站XML- 必应XML- 谷歌XML- 网站TXT- 友情链接- 加入收藏

    操盘手公式网   Copyright © 2010-2019   stock87.com™, All Rights Reserved.  浙ICP备17017803号
       免责声明:本站所有信息均免费。所有广告、涉及到的链接,如遇收费行为,均与本站无关!请股友自辨真假.
        本站内容为经验总结,部分源自网络,若无意侵犯了您的版权,请联系我站删除. 广告投放QQ:69948046.


    浙ICP备17017803号
    关闭
    关闭
    关闭
    关闭