「macd」背离+九转+空中加油融合指标图文,太强大了!-macd-操盘手公式网
选股公式
股市行情
抄底公式
股票行情 通达信 大智慧 同花顺 飞狐公式 股市 人民币 今日股市 股票行情 今日大盘 上证指数 指标 macd boll kdj obv cci rsi dmi sar vol ddx ddy wr ddz
股票软件 指数 创业板指数 科创板 美元指数 大盘指数 大盘 人民币汇率 美元汇率 英镑汇率 日元汇率 港币兑人民币 外汇 期货 基金 操盘手 股票入门 炒股技巧
/
当前位置:首页 >> 股票公式 >>  macd
今日股市行情
2021股票基础高级教程
「macd」背离+九转+空中加油融合指标图文,太强大了!
  • 相关简介: 今日股市
  • 内容标签: macd
  • 浏览次数:
  • 运行环境: Win10,Win8,Win7,WinXP
  • 文章作者: 操盘手公式网
  • 文章来源: www.stock87.com
  • 加入时间: 2020-09-29 08:21:04
  • 解压密码: www.stock87.com(请仔细输入!复制无效!)
  • 大盘指数
  • 软件下载说明:(注:已有源码的指标公式只需要复制源码,不提供文件下载!)

    macd背离+九转+空中加油融合指标图文,太强大了!

    用法:

    macd顶背离,macd底背离提示(形成会有文字提醒,钝化不代表一定会形成);

    ②高九,低九(遇9就转,有朋友说有未来也是在这里,出7或8有的情况下不一定会出9,创新低或创新高7或8会消失,但9只要出现就不会更改,也不会漂移,只看9操作就可以);

    ③MACD买点

    macd背离+九转+空中加油融合指标图文,太强大了!

    本文指标含有选股公式如下:

    DRAWutf-8(O>C,RGB(40,40,40),RGB(0,0,40),0,'01',0); {背景不要可删除}
    DIF:100*(EMA(CLOSE,12)-EMA(CLOSE,26)),COLORWHITE,LINETHICK1;
    DEA:EMA(DIF,9),COLORYELLOW,LINETHICK1;
    MACD:(DIF-DEA)*2,COLORSTICK;
    {
    STICKLINE((MACD>=0),0,MACD,2,-1),COLOR0000FF;
    STICKLINE(((MACD>=0) AND (MACD < REF(MACD,1))),0,MACD,2,0),COLOR0090FF;
    STICKLINE((MACD<0),0,MACD,2,0),COLORGREEN;
    STICKLINE(((MACD<0) AND (MACD > REF(MACD,1))),0,MACD,2,-1),COLORCYAN;
    STICKLINE(CROSS(DIF,0),0,MACD,2,0)COLORMAGENTA;
    STICKLINE(CROSS(0,DIF),0,MACD,2,0)COLORWHITE;
    }
    STICKLINE((MACD>=0),0,MACD,1,0),COLOR0000FF;
    STICKLINE(((MACD>=0) AND (MACD < REF(MACD,1))),0,MACD,1,-1),COLOR0090FF;
    STICKLINE((MACD<0),0,MACD,1,1),COLORGREEN;
    STICKLINE(((MACD<0) AND (MACD > REF(MACD,1))),0,MACD,1,0),COLORCYAN;
    STICKLINE(CROSS(DIF,0),0,MACD,1,0),COLORMAGENTA;
    STICKLINE(CROSS(0,DIF),0,MACD,1,0),COLORWHITE;
    FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
    FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
    FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);
    FH4:=FH1 AND FH2 AND ABS((DIF-DEA)/C)<0.018;
    FH5:=FH1 AND FH2 AND MACD<0.10;
    macd二次翻红:(FH3 OR FH4 OR FH5),COLORRED,NODRAW;
    低买:CROSS(DIF,DEA) AND DIF<0,COLORFF00FF,NODRAW;
    macd加油:CROSS(DIF,DEA) AND DIF>0,COLORYELLOW,NODRAW;
    DRAWICON(二次翻红,-0.05,1);
    DRAWTEXT(二次翻红,-0.15,'↖翻红'),COLORRED;
    DRAWTEXT(CROSS(DIF,DEA) AND DIF<0,DEA-0.02,'↖低买'),COLORFF00FF;
    DRAWTEXT(CROSS(DIF,DEA) AND DIF>0,DEA-0.05,'↖加油'),COLORYELLOW;
    XG:二次翻红 OR 低买 OR 加油,NODRAW;
    YLZC:=IF(CLOSE=INDEXC,(INDEXC+INDEXH+INDEXL+INDEXO)/4,AMOUNT/(VOL+0.01)/100);
    A1:=C>REF(C,4);
    NT:=BARSLASTCOUNT(A1);
    TJ11:=NT=9;
    TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
    AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;
    DRAWTEXT(AY>0,MACD*1.02,VAR2STR(AY,0)),COLORLIRED;
    DRAWTEXT(NT=9,MACD*1.02,'9'),COLORGREEN;
    B1:=C<REF(C,4);
    NT0:=BARSLASTCOUNT(B1);
    TJ21:=NT0=9 ;
    TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);
    AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;
    DRAWTEXT(AY1>0,MACD*0.98,VAR2STR(AY1,0)),COLORGREEN;
    DRAWTEXT(NT0=9,MACD*0.98,'9'),COLORRED;
    DRAWICON(CROSS(DIF,DEA),DEA,1);
    DRAWICON(CROSS(DEA,DIF),DEA,2);
    死叉:=CROSS(DEA,DIF);
    N1:=BARSLAST(死叉),NODRAW;{最近一次死叉的位置}
    N2:=REF(BARSLAST(死叉),N1+1),NODRAW;{倒数第二次死叉与倒数第一次死叉的区间}
    N3:=REF(BARSLAST(死叉),N2+N1+2),NODRAW;{倒数第三次死叉与倒数第二次死叉的区间}
    CL1:=LLV(C,N1+1),NODRAW;{最近一次死叉后,最低收盘价}
    DIFL1:=LLV(DIF,N1+1),NODRAW;
    CL2:=REF(CL1,N1+1),NODRAW;{倒数第二次死叉与倒数第一次死叉之间的最低收盘价}
    DIFL2:=REF(DIFL1,N1+1),NODRAW;
    CL3:=REF(CL2,N1+1),NODRAW;{倒数第三次死叉与倒数第二次死叉之间的最低收盘价}
    DIFL3:=REF(DIFL2,N1+1),NODRAW;
    PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
    MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
    PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
    MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
    MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
    MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
    直接底背离:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
    隔峰底背离:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
    底部钝化:直接底背离 OR 隔峰底背离,NODRAW;
    底背离:((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1)),NODRAW;
    底背离消失:=(REF(直接底背离,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背离,1) AND DIFL1<=DIFL3);
    {DRAWTEXT(TFILTER(底部钝化,(REF(DIF,1)>REF(DIF,2) AND DIF<REF(DIF,1)),1),DIFL2,'钝化'),COLORYELLOW;}
    STICKLINE(底部钝化,DIF,DEA,1,0),COLORMAGENTA;
    DRAWTEXT(TFILTER(底背离,C<REF(CL1,1),1),DIF*1.12,'结构形成'),COLORMAGENTA;
    {DRAWTEXT(FILTER(底背离消失,10),(DIF+MACD),'消失'),COLORGREEN;
    STICKLINE(底背离,0,(DIF+DEA),5,0), COLORRED;}
    金叉:=CROSS(DIF,DEA);
    M1:=BARSLAST(金叉),NODRAW;{最近一次金叉的位置}
    M2:=REF(BARSLAST(金叉),M1+1),NODRAW;{倒数第二次金叉与倒数第一次金叉的区间}
    M3:=REF(BARSLAST(金叉),M2+M1+2),NODRAW;{倒数第三次金叉与倒数第二次金叉的区间}
    CH1:=HHV(C,M1+1),NODRAW;{最近一次金叉后,最高收盘价}
    DIFH1:=HHV(DIF,M1+1),NODRAW;
    CH2:=REF(CH1,M1+1),NODRAW;{倒数第二次金叉与倒数第一次金叉之间的最高收盘价}
    DIFH2:=REF(DIFH1,M1+1),NODRAW;
    CH3:=REF(CH2,M1+1),NODRAW;{倒数第三次金叉与倒数第二次金叉之间的最高收盘价}
    DIFH3:=REF(DIFH2,M1+1),NODRAW;
    PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
    MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
    PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
    MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
    MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
    MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
    直接顶背离:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
    隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
    顶部钝化:直接顶背离 OR 隔峰顶背离,NODRAW;
    顶背离:((MDIFT2<REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰顶背离,1)),NODRAW;
    {DRAWTEXT(TFILTER(T,(REF(DIF,1)<REF(DIF,2) AND DIF>REF(DIF,1)),1),DIFH2,'钝化开始'),COLORYELLOW;}
    STICKLINE(顶部钝化,DIF,DEA,1,0),COLORGREEN;
    DRAWTEXT(TFILTER(顶背离,C>REF(CH1,1),1),DIF*1.12,'结构形成'),COLORGREEN;
    DRAWICON(CROSS(DIF,DEA),DEA,36);
    DRAWICON(CROSS(DEA,DIF),DEA,37);
    MACDDIF:=IF(ABS(MACD)>ABS(DIF),MACD,DIF);
    DRAWICON(REF(DIF,1)>REF(DIF,2) AND DIF<REF(DIF,1) AND DIF>0 AND DIF>DEA,MACDDIF*1.1,39),COLORGREEN;
    DRAWICON(REF(DIF,1)<REF(DIF,2) AND DIF>REF(DIF,1) AND DIF<0 AND DIF<DEA,MACDDIF*1.1,38),COLORRED;

    macd:http://www.stock87.com

    版权保护: 本文由「操盘手公式网」编辑发布 转载请注明出处

    文章链接:

    人民币汇率
    股票开户

    免费下载提示:(下载本站资源请点下方“蓝色图标”进入下载页)

    官方千人交流Q群8:1500113880

    官方千人交流微信群1:rafczx



    热门文章Top
  • 安倍内阁支持率自2月来首次跌破50%「美金兑人民币昨日汇率」被指违反政治资金法_汇率
  • 大华银行「美金兑人民币今日汇率是多少」:欧元/美元指数将进入盘整 波动范围1.1010-1.1115_汇率
  • 摩根士丹利本周交易精选:「人民币换算泰铢」买入纽元/加元_汇率
  • 汇率:市场突然“反转”!黄金触底大反弹近15「人民币对美元汇率k线图」美元指数……_汇率
  • 美国股市再创纪录收盘新高,但市场交投「在美国 兑换人民币 汇率」相对清淡_汇率
  • 油价下跌逾1%,抹去了上周的大部分涨幅_汇「货币兑换」率
  • 特朗普与鲍威尔隔夜罕见会晤!美元指数成“惊弓之鸟”惨遭抛售_「美金图片」汇率
  • 澳洲联储纪要称必要时将进「外汇牌价查询日元」一步宽松澳元亚市急跌_汇率
  • 土耳其总统埃尔多安:已告知特朗普土「日历2021年假期表」耳其不会放弃S-400_汇率
  • 特朗普再怎么高喊负「加元兑美元汇率分析」利率也没用?美联储鹰派声音已愈发嘹亮!_汇率
  • 与其担忧强势美元指数,特朗普不如反思一下贸易政策对制造业的伤害「什么是kdj线」_汇率
  • 特朗普称他将考虑在弹「美元指数走势图」劾调查中作证_汇率
  • 「美金兑换人民币汇率怎么换算合理」美金汇率:英国大选存黑天鹅可能,英镑料止步四连阳;俄排斥深化减产,美油跌逾1.6%_汇率
  • 汇丰:政治角「欧元兑换人民币汇率查询今日价格」力结果将决定英镑的未来_汇率
  • 易纲称央行要发挥好LPR引导作用促进实际贷款利「中信证券软件下载」率下行_汇率
  • 【欧盘必读】美元指数弱势防守、已经短线筑顶?英镑四连阳筹划更大突破_汇「日元换算美元」率
  • 美元指数企稳结束连续三日跌势今晚美联储纪要「港币兑美元」料再掀汇市波澜_汇率
  • 谈判前景转淡人民币缩量收跌「人民币汇率走势」至半个月新低短期料难出方向_汇率
  • 英国大选首场电视辩论结束科尔宾缩小与约翰逊的差距_汇「国际汇率查询用什么软件」率
  • 中国央行送上年底大礼包:LPR下调5个基点5年期为「日币对人民币汇率换算」首次回落_汇率

  • 股票配资广告- 广告合作- 下载声明- 免费下载- 网站地图- 网站XML- 股票公式- 谷歌XML 网站TXT- 公式网- 加入收藏

     Copyright © 2020   操盘手公式网 (www.stock87.com) ,  All Rights Reserved.       广告合作QQ: 69948046

    为股民提供指标公式,选股公式,股票公式,股票软件,股票入门基础知识,日元对人民币汇率,股市行情,人民币汇率,美元对人民币汇率,股票行情,今日股市行情,股吧,指标公式网

    内容来源于网络,若无意中侵犯您的版权,请联系删除!


    浙ICP备17017803号-1